[PATCH, v2] [AArch64] Support AArch64 MTE memory tag dumps in core files

Luis Machado luis.machado@arm.com
Tue May 3 11:23:19 GMT 2022


Hi Alan,

On 4/23/22 01:15, Alan Modra wrote:
> On Thu, Apr 21, 2022 at 04:18:41PM +0100, Luis Machado wrote:
>> v2:
>>
>> - Drop arch-specific fields from the generic section data structure.
>> - Use the rawsize field of the section structure to store the original
>>    memory range of the memory-tagged area.
>> - Implement the bfd_elf_modify_headers for aarch64, to adjust the values
>>    for the memory tag segment according to the Linux Kernel's format.
> 
> This looks OK to me, except for defining PT_ARM_MEMTAG_MTE in
> elf/common.h.  That belongs in elf/aarch64.h.  BTW, why isn't the
> header called PT_AARCH64_MEMTAG_MTE?  Using PT_ARM_ looks odd,
> considering that we already have PT_ARM_EXIDX at LOPROC+1.
> 

Your comment made me go back and chase the reason behind this naming. 
Turns out we should really be naming it PT_AARCH64_MEMTAG_MTE. While at 
it we should also update the constant value given there is a another 
AArch64 segment type using PT_LOPROC + 1, one that is not yet known to 
binutils-gdb.

I'll send a v3.


Thanks,
Luis


More information about the Binutils mailing list