[PATCH] ld: Add a before_plugin_all_symbols_read hook
H.J. Lu
hjl.tools@gmail.com
Thu Mar 10 02:23:26 GMT 2022
On Wed, Mar 9, 2022 at 5:20 PM Alan Modra <amodra@gmail.com> wrote:
>
> On Tue, Mar 08, 2022 at 09:22:30AM -0800, H.J. Lu via Binutils wrote:
> > Add a before_plugin_all_symbols_read hook to load symbol references from
> > DT_NEEDED entries, included from --copy-dt-needed-entries, before reading
> > plugin symbols to properly resolve plugin symbol references.
>
> OK, except
>
> > * elf-bfd.h (elf_link_hash_table): Add
> > before_plugin_all_symbols_read.
>
> please change the name of this flag to better reflect what it does.
> "handling_dt_needed" perhaps. You set and clear the flag around the
Done. This is the v2 patch I am checking in.
Thanks.
> new ldelf_handle_dt_needed function. It isn't set before
> plugin_call_all_symbols_read and clear afterwards.
>
> --
> Alan Modra
> Australia Development Lab, IBM
--
H.J.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: v2-0001-ld-Add-a-before_plugin_all_symbols_read-hook.patch
Type: text/x-patch
Size: 23195 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/binutils/attachments/20220309/729f37fc/attachment-0001.bin>
More information about the Binutils
mailing list