[PATCH] ELF: Move tlsdesc_plt/tlsdesc_got to elf_link_hash_table

Alan Modra amodra@gmail.com
Wed Jun 10 06:29:31 GMT 2020


On Sun, Jun 07, 2020 at 06:56:51AM -0700, H.J. Lu via Binutils wrote:
> tlsdesc_plt and tlsdesc_plt are together:
> 
>   /* The offset into splt of the PLT entry for the TLS descriptor
>      resolver.  Special values are 0, if not necessary (or not found
>      to be necessary yet), and -1 if needed but not determined
>      yet.  */
>   bfd_vma tlsdesc_plt;
> 
>   /* The GOT offset for the lazy trampoline.  Communicated to the
>      loader via DT_TLSDESC_GOT.  The magic value (bfd_vma) -1
>      indicates an offset is not allocated.  */
>   bfd_vma tlsdesc_got;
> 
> Here is the updated patch to move them together.   I'd like to check it
> into master if there are no objections.

OK.

-- 
Alan Modra
Australia Development Lab, IBM


More information about the Binutils mailing list