Commit: PR 25747: Tell users about a missing "lib" prefix to library names

Maciej W. Rozycki macro@linux-mips.org
Wed Apr 1 17:19:20 GMT 2020


On Wed, 1 Apr 2020, Nick Clifton via Binutils wrote:

> diff --git a/ld/ldfile.c b/ld/ldfile.c
> index aa84906992..3248a04607 100644
> --- a/ld/ldfile.c
> +++ b/ld/ldfile.c
> @@ -445,6 +445,22 @@ ldfile_open_file (lang_input_statement_type *entry)
>  		   entry->local_sym_name, ld_sysroot);
>  	  else
>  	    einfo (_("%P: cannot find %s\n"), entry->local_sym_name);
> +
> +	  /* PR 25747: Be kind to users who forgot to add the
> +	     "lib" prefix to their library when it was created.  */
> +	  for (arch = search_arch_head; arch != NULL; arch = arch->next)
> +	    {
> +	      if (ldfile_open_file_search (arch->name, entry, "", ".a"))
> +		{
> +		  const char * base = lbasename (entry->filename);
> +
> +		  einfo (_("%P: note to link with %s use use -l:%s or rename it to lib%s\n"),

 s/use use/use/ I presume here.

 Can you please match the heading of the change committed with the subject 
of the corresponding message sent to the mailing list (as `git am' would)?  
It will make it easier to chase any discussion corresponding to a commit 
when someone does repo excavation in the future.

  Maciej



More information about the Binutils mailing list