PR binutils/23013: Assembler not recognizing 3-opt dcbt instruction form on Power systems
Peter Bergner
bergner@vnet.ibm.com
Fri Mar 30 14:42:00 GMT 2018
On 3/29/18 10:14 PM, Alan Modra wrote:
> On Thu, Mar 29, 2018 at 09:40:27PM -0500, Peter Bergner wrote:
>> On 3/29/18 8:29 PM, Alan Modra wrote:
>>> On Thu, Mar 29, 2018 at 02:56:24PM -0500, Peter Bergner wrote:
>>> Write the above line as
>>>
>>> ppc_cpu |= (PPC_OPCODE_PPC | PPC_OPCODE_ISEL | PPC_OPCODE_64
>>
>> Hmmm.... or maybe the following is more readable?
>
> Fine, but "|=" not "=", to preserve -many.
Ok, I committed the patch with that change. Thanks.
Peter
More information about the Binutils
mailing list