[gold commit] Use top-level config support for enabling plugins

Cary Coutant ccoutant@gmail.com
Wed Mar 28 21:07:00 GMT 2018


This patch modifies the gold configure script to use AC_PLUGINS from
config/plugins.m4 (PR 21423). I've also modified the options parser to
recognize the --plugin options even when plugins are disabled, and
print a suitable error message (PR 22500).

-cary

2018-03-28  Cary Coutant  <ccoutant@gmail.com>

gold/
        PR gold/21423
        PR gold/22500
        * configure.ac: Call AC_USE_SYSTEM_EXTENSIONS.
        Replace check for --enable-plugins with AC_PLUGINS.
        * options.cc (parse_plugin, parse_plugin_opt): Remove #ifdef.
        (General_options::finalize): Check if plugins enabled.
        * options.h (--plugin, --plugin-opt): Define even if plugins not
        enabled.
        * Makefile.in: Regenerate.
        * aclocal.m4: Regenerate.
        * configure: Regenerate.
        * testsuite/Makefile.in: Regenerate.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: plugin-config.patch
Type: application/octet-stream
Size: 3385 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/binutils/attachments/20180328/6316de34/attachment.obj>


More information about the Binutils mailing list