[PATCH] gold: Provide more failed archive member info in error message

H.J. Lu hjl.tools@gmail.com
Thu Dec 6 14:08:00 GMT 2018


On Tue, Dec 4, 2018 at 5:35 AM H.J. Lu <hjl.tools@gmail.com> wrote:
>
> On Tue, Dec 4, 2018 at 12:00 AM Cary Coutant <ccoutant@gmail.com> wrote:
> >
> > > +  bool plugin_failed = false;
> > >
> > >    if (is_elf_object(input_file, memoff, &ehdr, &read_size))
> > >      {
> > > @@ -716,12 +717,20 @@ Archive::get_elf_object_for_member(off_t off, bool* punconfigured)
> > >             delete obj;
> > >            return plugin_obj;
> > >          }
> > > +
> > > +      plugin_failed = true;
> >
> > An unclaimed file is not a plugin "failure". I'd prefer to name this
> > variable "unclaimed".
> >
>
> Like this?
>

I will check it in.


-- 
H.J.



More information about the Binutils mailing list