On Fri, Jun 02, 2017 at 01:23:40AM +0100, Maciej W. Rozycki wrote: > I'll go with: > > size = o->reloc_count; > size *= sizeof (Elf_Internal_Rela); > > then if you don't mind. I find explicit casts worsen code readability. Fine by me. -- Alan Modra Australia Development Lab, IBM