[PATCH 5/8] Remove magic numbers in m68k-dis.c:print_insn_arg
Yao Qi
qiyaoltc@gmail.com
Fri Jan 13 12:23:00 GMT 2017
On 17-01-12 08:44:06, Alan Modra wrote:
> On Tue, Jan 10, 2017 at 12:26:15PM +0000, Yao Qi wrote:
> > * m68k-dis.c (enum print_insn_arg_error): New.
> > (NEXTBYTE): Replace -3 with
> > PRINT_INSN_ARG_MEMORY_ERROR.
> > (NEXTULONG): Likewise.
> > (NEXTSINGLE): Likewise.
> > (NEXTDOUBLE): Likewise.
> > (NEXTDOUBLE): Likewise.
> > (NEXTPACKED): Likewise.
> > (FETCH_DATA): Update comments.
> > (print_insn_arg): Update comments. Replace magic numbers with
> > enum.
> > (match_insn_m68k): Likewise.
>
> OK.
>
Patch is pushed in.
--
Yao (é½å°§)
More information about the Binutils
mailing list