[gold][PATCH] Add chdr_size, Chdr, Chdr_write and Chdr_data

Cary Coutant ccoutant@google.com
Wed Apr 8 17:14:00 GMT 2015


> This patch adds chdr_size, Chdr, Chdr_write and Chdr_data.  OK for
> master?
>
>
> H.J.
> ---
>         * elfcpp.h (Elf_sizes): Add chdr_size.
>         (Chdr): New.
>         (Chdr_write): Likewise.
>         * elfcpp_internal.h (Chdr_data): Likewise.

> +  void
> +  put_ch_tye(typename Elf_types<size>::Elf_WXword v)
> +  { this->p_->ch_type = Convert<size, big_endian>::convert_host(v); }

s/put_ch_tye/put_ch_type/

OK with that fix. Thanks!

-cary



More information about the Binutils mailing list