[RFC][MIPS] What to do about DT_MIPS_RLD_MAP and PIE
Maciej W. Rozycki
macro@codesourcery.com
Thu Oct 30 18:46:00 GMT 2014
On Thu, 30 Oct 2014, Matthew Fortune wrote:
> OK, let's go with that. Time to decide on a name. How about
> DT_MIPS_RLD_MAP_PIE? Long but potentially accurate. We are going to have to
> drag around DT_MIPS_RLD_MAP forever I believe so I suggest we focus the
> new name on the scenario where it is required.
As noted in the other e-mail I suggest using it everywhere, for
uniformity, and I think using the old name for the new assignment should
provide maximum compatibility. We could rename the old assignment to
DT_MIPS_RLD_MAP_LEGACY then.
Can you think of a scenario where it would not work?
Alternatively, we could cook up a generic DT_GNU_RLD_MAP tag for
platforms that want to opt in to a read-only dynamic section/segment and
start using it with the MIPS target first. I think I like the latter a
bit better, any thoughts, anyone?
Maciej
More information about the Binutils
mailing list