[PATCH] ld/aarch64: xfail non-PIC shared object tests on aarch64

Will Newton will.newton@linaro.org
Fri May 16 14:41:00 GMT 2014


On 16 May 2014 15:35, Richard Earnshaw <rearnsha@arm.com> wrote:
> On 16/05/14 15:26, Will Newton wrote:
>> aarch64 does not support building non-PIC shared objects, so mark
>> tests for these as xfail.
>>
>> 2014-05-16  Will Newton  <will.newton@linaro.org>
>>
>>       * ld-shared/shared.exp: Mark non-PIC shared object tests
>>       as xfail on aarch64.
>> ---
>>  ld/testsuite/ld-shared/shared.exp | 3 +++
>>  1 file changed, 3 insertions(+)
>>
>> diff --git a/ld/testsuite/ld-shared/shared.exp b/ld/testsuite/ld-shared/shared.exp
>> index 9996ece..c723ef7 100644
>> --- a/ld/testsuite/ld-shared/shared.exp
>> +++ b/ld/testsuite/ld-shared/shared.exp
>> @@ -244,6 +244,7 @@ if ![ld_compile "$CC $CFLAGS $SHCFLAG" $srcdir/$subdir/main.c $tmpdir/mainnp.o]
>>       if [ string match $shared_needs_pic "yes" ] {
>>           setup_xfail "arm*-*-linux*"
>>       }
>> +     setup_xfail "aarch64*-*-linux*"
>
> Shouldn't this (and the other cases) be inside the test immediately
> above (shared_needs_pic)?

shared_needs_pic is rather misnamed. It means "does this ARM compiler
emit MOVW instructions".

>
>>       shared_test shnp "shared (non PIC)" mainnp.o sh1np.o sh2np.o shared
>>
>>       # Test ELF shared library relocations with a non-zero load
>> @@ -270,6 +271,7 @@ if ![ld_compile "$CC $CFLAGS $SHCFLAG" $srcdir/$subdir/main.c $tmpdir/mainnp.o]
>>       if [ string match $shared_needs_pic "yes" ] {
>>           setup_xfail "arm*-*-linux*"
>>       }
>> +     setup_xfail "aarch64*-*-linux*"
>>       shared_test shnp "shared (non PIC, load offset)" \
>>               mainnp.o sh1np.o sh2np.o shared \
>>               "-T $srcdir/$subdir/elf-offset.ld"
>> @@ -326,6 +328,7 @@ if ![ld_compile "$CC $CFLAGS $SHCFLAG $picflag" $srcdir/$subdir/main.c $tmpdir/m
>>           if [ string match $shared_needs_pic "yes" ] {
>>               setup_xfail "arm*-*-linux*"
>>           }
>> +         setup_xfail "aarch64*-*-linux*"
>>           shared_test shmpnp "shared (PIC main, non PIC so)" mainp.o sh1np.o sh2np.o shared
>>       }
>>      } else {
>>
>
>



-- 
Will Newton
Toolchain Working Group, Linaro



More information about the Binutils mailing list