[MIPS][committed] Rename COPROC related macros
Matthew Fortune
Matthew.Fortune@imgtec.com
Tue Jul 29 13:42:00 GMT 2014
A mechanical patch to remove the word 'DELAY' from two attributes in
the MIPS opcode tables. This has been changed as the attributes are now
applied to micromips instructions (as required by the code which handles
-mno-odd-spreg). The micromips instructions will never need NOPs inserting
as they have always interlocked correctly so the 'delay' is meaningless
and confusing for the new uses. There is no functional change in this
patch.
Tested with mips64-linux-gnu and applied.
Thanks,
Matthew
gas/
* config/tc-mips.c: Rename INSN_LOAD_COPROC_DELAY to INSN_LOAD_COPROC
and INSN_COPROC_MOVE_DELAY to INSN_COPROC_MOVE throughout.
include/opcode/
* mips.h (INSN_LOAD_COPROC_DELAY): Rename to...
(INSN_LOAD_COPROC): New define.
(INSN_COPROC_MOVE_DELAY): Rename to...
(INSN_COPROC_MOVE): New define.
opcodes/
* micromips-opc.c (COD): Rename throughout to...
(CM): New define, update to use INSN_COPROC_MOVE.
(LCD): Rename throughout to...
(LC): New define, update to use INSN_LOAD_COPROC.
* mips-opc.c: Likewise
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-MIPS-Rename-COPROC-related-macros.patch
Type: application/octet-stream
Size: 39277 bytes
Desc: 0001-MIPS-Rename-COPROC-related-macros.patch
URL: <https://sourceware.org/pipermail/binutils/attachments/20140729/6d298d0e/attachment.obj>
More information about the Binutils
mailing list