PATCH: Add R_386_SIZE32/R_X86_64_SIZE32/R_X86_64_SIZE64 support to bfd
David Miller
davem@davemloft.net
Wed Jan 16 21:46:00 GMT 2013
From: "H.J. Lu" <hongjiu.lu@intel.com>
Date: Wed, 16 Jan 2013 13:42:29 -0800
> I checked in this patch to add R_386_SIZE32, R_X86_64_SIZE32 and
> R_X86_64_SIZE64 support to bfd. I added generic BFD_RELOC_SIZE32
> and BFD_RELOC_SIZE64 since it is a generic feature supported on
> x86 and Sparc. I am expecting that other targets may support them
> in the future. If it isn't acceptable, I will rename them to x86
> specific names.
I think having a generic BFD_RELOC_SIZE{32,64} is the right thing
to do.
More information about the Binutils
mailing list