Linker scripts and Section Reordering.
Ian Lance Taylor
iant@google.com
Wed Jan 9 23:54:00 GMT 2013
On Wed, Jan 9, 2013 at 3:40 PM, Sriraman Tallam <tmsriram@google.com> wrote:
>
> It seems like this is needed in
> Orphan_output_section::set_section_addresses too. I can have cases
> where there are multiple input sections with the same name that are
> not referenced by the linker script. They will all be grouped under
> one Orphan_output_section and this can be reordered later. I have
> attached the new patch with this correction. Sorry about the
> confusion. I have attached the new patch. I duplicated the code in
> set_section_addresses. I did not create a new function as only the
> comments are long and repeating.
This is OK too.
Thanks.
Ian
More information about the Binutils
mailing list