[committed] Replace field-based RD_ and WR_ flags with position-based ones

Richard Sandiford rdsandiford@googlemail.com
Thu Aug 1 22:36:00 GMT 2013


Richard Sandiford <rdsandiford@googlemail.com> writes:
> This patch replaces field-based flags like RD_s, WR_d, etc., with
> position-based ones like WR_1 (write to first operand), RD_2, etc.

Just noticed that I'd left a dangling WR_s in micromips-opc.c.  Also,
I forgot to say that I'd kept RD_a and WR_a as aliases for now,
both because we don't really model the ACX component properly and
because there doesn't seem to be a real need to distinguish $ac0-$ac3
in GAS at the moment.

Richard


opcodes/
	* micromips-opc.c (WR_s): Delete.

Index: opcodes/micromips-opc.c
===================================================================
--- opcodes/micromips-opc.c	2013-08-01 21:54:51.901028141 +0100
+++ opcodes/micromips-opc.c	2013-08-01 23:28:44.919946043 +0100
@@ -196,7 +196,6 @@ #define RD_31	INSN2_READ_GPR_31
 #define RD_pc	INSN2_READ_PC
 
 /* For 32-bit microMIPS instructions.  */
-#define WR_s	INSN_WRITE_GPR_S
 #define WR_31	INSN_WRITE_GPR_31
 #define WR_CC	INSN_WRITE_COND_CODE
 



More information about the Binutils mailing list