[Patch, AArch64] change gas arch option name 'armv8' to 'armv8-a'
Yufeng Zhang
Yufeng.Zhang@arm.com
Tue Sep 18 12:45:00 GMT 2012
Add Tristan to the recipient list.
Yufeng
On 09/17/12 18:50, Richard Earnshaw wrote:
> On 17/09/12 17:52, Yufeng Zhang wrote:
>> This needs to go into the 2.23 branch as well.
>>
>
> I've committed this, and I agree about being needed in 2.23.
>
> Tristan, the cvs commit is:
>
> http://sourceware.org/ml/binutils-cvs/2012-09/msg00102.html
>
> R.
>
>> Thanks,
>> Yufeng
>>
>> On 01/-10/37 20:59, Yufeng Zhang wrote:
>>> Hi,
>>>
>>> This patch updates the AArch64 gas -march option name from 'armv8' to
>>> 'armv8-a' to be in alignment with AArch64 gcc and 32-bit ARM binutils etc.
>>>
>>> Is it OK to commit?
>>>
>>> Thanks,
>>> Yufeng
>>>
>>>
>>>
>>> gas/
>>>
>>> 2012-09-17 Yufeng Zhang<yufeng.zhang@arm.com>
>>>
>>> * config/tc-aarch64.c (aarch64_archs): Rename 'armv8' to 'armv8-a'.
>>>
>>> gas/testsuite/
>>>
>>> 2012-09-17 Yufeng Zhang<yufeng.zhang@arm.com>
>>>
>>> * gas/aarch64/crypto.d (#as): Update.
>>> * gas/aarch64/int-insns.d (#as): Update.
>>> * gas/aarch64/legacy_reg_names.s (.arch): Update.
>>> * gas/aarch64/neon-not.s (.arch): Update.
>>> * gas/aarch64/neon-vfp-reglist-post.s (.arch): Update.
>>> * gas/aarch64/neon-vfp-reglist.s (.arch): Update.
>>
>>
>>
>>
>>
>
>
>
More information about the Binutils
mailing list