[Patch,AVR]: ad PR13503: Rename expression modifiers/RELOCs "hhi8" for data.
Wed May 16 13:05:00 GMT 2012
nick clifton wrote:
> Hi Johann,
> Thanks for your patience in getting this patch in to the binutils
> sources. I have now reviewed the patch, found no problems with it, and
> checked it in to the repository.
thanks for applying the patch.
There is a typo: The right alias for "hh8" modifier (byte #2) is "hlo8"
and not "hhi8".
This is a follow-up addendum to fix that misnomer. It also renames
the involved RELOCs so that no confusion will arise in the future.
The feature itself is unchanged. "hhi8", i.e. the 3rd byte of an
expression, not needed because there are no 4-byte addresses.
* reloc.c: Rename BFD_RELOC_AVR_8_HHI to BFD_RELOC_AVR_8_HLO.
* bfd-in2.h: Regenerate.
* libbfd.h: Regenrate.
* elf32-avr.c (elf_avr_howto_table): Rename R_AVR_8_HHI8 to
* config/tc-avr.c (avr_cons_fix_new): Rename R_AVR_8_HHI8 to
(exp_mod_data) Ditto. And replace "hhi8" with "hlo8".
(md_apply_fix): Rename BFD_RELOC_AVR_8_HHI to BFD_RELOC_AVR_8_HLO.
* elf/avr.h (RELOC_NUMBERS): Rename R_AVR_8_HHI8 to R_AVR_8_HLO8.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 5782 bytes
Desc: not available
More information about the Binutils