[Patch] Fix PR 13591
Tristan Gingold
gingold@adacore.com
Thu Jan 12 08:38:00 GMT 2012
Hi,
this patch fixes a fallout of my previous patch (about struct symbol_flags). Ok to commit ?
No regression in gas test suite for i386-mingw32.
Tristan.
2012-01-12 Tristan Gingold <gingold@adacore.com>
PR gas/13591
* config/obj-coff.h (sy_obj): Rename macro to avoid a name conflict.
diff --git a/gas/config/obj-coff.h b/gas/config/obj-coff.h
index fb9c6be..ff5548e 100644
--- a/gas/config/obj-coff.h
+++ b/gas/config/obj-coff.h
@@ -181,7 +181,7 @@
#endif
#define OBJ_SYMFIELD_TYPE unsigned long
-#define sy_obj sy_flags
+#define sy_obj sy_obj_flags
/* We can't use the predefined section symbols in bfd/section.c, as
COFF symbols have extra fields. See bfd/libcoff.h:coff_symbol_type. */
More information about the Binutils
mailing list