On 23 Feb 2012, at 14:43, Tristan Gingold wrote: >> so, how about this? > > Yes, looks good. One minor nit, see below. Thanks, fixed. > I think the usual name in BFD for encode/decode is swap in/swap > out. Feel free to rename. changed the names and applied Iain