[gold patch] Incremental 13/18: Dynamic relocations

Cary Coutant ccoutant@google.com
Tue May 24 18:36:00 GMT 2011

> Sized_relobj_base is turning into a poor choice of names.  It looks the
> heirarchy is now
> Object
> Relobj
> Sized_relobj_base
> Sized_relobj / Sized_incr_relobj
> I don't mind having Sized_relobj_base when just a couple of things refer
> to it, but it looks wrong when lots of functions use it.  The name of a
> class should indicate what sort of thing it is, rather than its position
> in the class heirarchy.  We should consider renaming, e.g.,
> Sized_relobj_base => Sized_relobj, Sized_relobj => Sized_relobj_file,
> Sized_incr_relobj => Sized_relobj_incr.  I'm open to other suggestions.

Yeah, I started out with something like this, but (a) I couldn't come
up with a name I liked for Sized_relobj_file, and (b) I was trying to
avoid wholesale changes to so many other files that were otherwise

In the ChangeLog, should I enumerate all the files touched, or is it
better to just say "Rename x to y; change all references" in object.h?


More information about the Binutils mailing list