[PATCH] add bdver2 processor.
Quentin Neill
quentin.neill.gnu@gmail.com
Thu May 12 02:17:00 GMT 2011
On Wed, May 11, 2011 at 9:24 AM, Quentin Neill
<quentin.neill.gnu@gmail.com> wrote:
> On Wed, May 11, 2011 at 1:40 AM, Jan Beulich <JBeulich@novell.com> wrote:
>>>>> On 10.05.11 at 21:10, "H.J. Lu" <hjl.tools@gmail.com> wrote:
>>> On Tue, May 10, 2011 at 11:28 AM, Quentin Neill
>>>> Should I rename the PROCESSOR_BDVER1 variable to perhaps PROCESSOR_BDVER?
>>>
>>> Sounds good to me.
>>
>> And in a couple of years from now nobody will be able to tell what the
>> "VER" in the name stands for ...
>>
>> Jan
>
> I thought of that last night when I got home.
>
> I'll change it to PROCESSOR_BD with another patch.
> --
> Quentin
So attached is the tested PROCESSOR_BD variable rename patch, which
passes "make check" in x86_64.
Okay to commit?
--
Quentin
P.S. I noticed that on yesterday's cvs commit I neglected commit the
opcodes/ directory; ARG! I went ahead and did that before this
patch.
-------------- next part --------------
From 5cfb2a9d93899f7920b70306f5a1c12d543fcbc3 Mon Sep 17 00:00:00 2001
From: Quentin Neill <quentin.neill@amd.com>
Date: Wed, 11 May 2011 21:10:05 -0500
Subject: [PATCH] 2011-05-11 Quentin Neill <quentin.neill@amd.com>
* config/tc-i386.c (cpu_arch): Rename PROCESSOR_BDVER1 to PROCESSOR_BD.
(i386_align_code): Ditto
---
gas/ChangeLog | 5 +++++
gas/config/tc-i386.c | 10 +++++-----
gas/config/tc-i386.h | 2 +-
3 files changed, 11 insertions(+), 6 deletions(-)
diff --git a/gas/ChangeLog b/gas/ChangeLog
index 56a0177..db1aa3c 100644
--- a/gas/ChangeLog
+++ b/gas/ChangeLog
@@ -1,3 +1,8 @@
+2011-05-11 Quentin Neill <quentin.neill@amd.com>
+
+ * config/tc-i386.c (cpu_arch): Rename PROCESSOR_BDVER1 to PROCESSOR_BD.
+ (i386_align_code): Ditto
+
2011-05-10 Quentin Neill <quentin.neill@amd.com>
* config/tc-i386.c (cpu_arch): Add bdver2 and rename
diff --git a/gas/config/tc-i386.c b/gas/config/tc-i386.c
index d208a0d..8bbf9db 100644
--- a/gas/config/tc-i386.c
+++ b/gas/config/tc-i386.c
@@ -645,9 +645,9 @@ static const arch_entry cpu_arch[] =
CPU_K8_FLAGS, 0, 0 },
{ STRING_COMMA_LEN ("amdfam10"), PROCESSOR_AMDFAM10,
CPU_AMDFAM10_FLAGS, 0, 0 },
- { STRING_COMMA_LEN ("bdver1"), PROCESSOR_BDVER,
+ { STRING_COMMA_LEN ("bdver1"), PROCESSOR_BD,
CPU_BDVER1_FLAGS, 0, 0 },
- { STRING_COMMA_LEN ("bdver2"), PROCESSOR_BDVER,
+ { STRING_COMMA_LEN ("bdver2"), PROCESSOR_BD,
CPU_BDVER2_FLAGS, 0, 0 },
{ STRING_COMMA_LEN (".8087"), PROCESSOR_UNKNOWN,
CPU_8087_FLAGS, 0, 0 },
@@ -1025,7 +1025,7 @@ i386_align_code (fragS *fragP, int count)
PROCESSOR_CORE, PROCESSOR_CORE2, PROCESSOR_COREI7, and
PROCESSOR_GENERIC64, alt_long_patt will be used.
3. For PROCESSOR_ATHLON, PROCESSOR_K6, PROCESSOR_K8 and
- PROCESSOR_AMDFAM10, and PROCESSOR_BDVER, alt_short_patt
+ PROCESSOR_AMDFAM10, and PROCESSOR_BD, alt_short_patt
will be used.
When -mtune= isn't used, alt_long_patt will be used if
@@ -1078,7 +1078,7 @@ i386_align_code (fragS *fragP, int count)
case PROCESSOR_ATHLON:
case PROCESSOR_K8:
case PROCESSOR_AMDFAM10:
- case PROCESSOR_BDVER:
+ case PROCESSOR_BD:
patt = alt_short_patt;
break;
case PROCESSOR_I386:
@@ -1107,7 +1107,7 @@ i386_align_code (fragS *fragP, int count)
case PROCESSOR_ATHLON:
case PROCESSOR_K8:
case PROCESSOR_AMDFAM10:
- case PROCESSOR_BDVER:
+ case PROCESSOR_BD:
case PROCESSOR_GENERIC32:
/* We use cpu_arch_isa_flags to check if we CAN optimize
with nops. */
diff --git a/gas/config/tc-i386.h b/gas/config/tc-i386.h
index bbe71e0..092e8c6 100644
--- a/gas/config/tc-i386.h
+++ b/gas/config/tc-i386.h
@@ -230,7 +230,7 @@ enum processor_type
PROCESSOR_GENERIC32,
PROCESSOR_GENERIC64,
PROCESSOR_AMDFAM10,
- PROCESSOR_BDVER
+ PROCESSOR_BD
};
extern enum processor_type cpu_arch_tune;
--
1.7.1
More information about the Binutils
mailing list