[2/6][PATCH] Do not use dummy bfd suffix for recognition, make it human-readable instead.
Dave Korn
dave.korn.cygwin@gmail.com
Sat Feb 26 00:46:00 GMT 2011
Hi list,
Removes the ugly name suffix from the dummy IR BFDs as previously discussed.
ld/ChangeLog:
2011-02-20 Dave Korn <...
* plugin.c (IRONLY_SUFFIX): Revise to nicely human-readable form.
(IRONLY_SUFFIX_LEN): Delete.
(plugin_get_ir_dummy_bfd): Don't append IRONLY_SUFFIX.
(is_ir_dummy_bfd): Don't look for suffix; check claimed flag of
enclosing lang input statement instead.
Think this one is straightforward and uncontroversial now.
cheers,
DaveK
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 002ld-plugin-api-no-ironly-suffix.diff
Type: text/x-c
Size: 2246 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/binutils/attachments/20110226/2143a284/attachment.bin>
More information about the Binutils
mailing list