PATCH: Also expect .zdebug in debug section name
Jan Beulich
JBeulich@novell.com
Mon Nov 15 15:36:00 GMT 2010
>>> On 15.11.10 at 14:12, "H.J. Lu" <hjl.tools@gmail.com> wrote:
> On Mon, Nov 15, 2010 at 12:05 AM, Jan Beulich <JBeulich@novell.com> wrote:
>>>>> On 13.11.10 at 17:16, "H.J. Lu" <hongjiu.lu@intel.com> wrote:
>>> --- a/binutils/testsuite/binutils-all/testranges.d
>>> +++ b/binutils/testsuite/binutils-all/testranges.d
>>> @@ -4,7 +4,7 @@
>>> #name: unordered .debug_info references to .debug_ranges
>>> #not-target: ia64-*-*
>>>
>>> -Contents of the .debug_ranges section:
>>> +Contents of the \.(z|)debug_ranges section:
>>
>> Why not \.z?debug_ranges ?
>>
>
> What is the difference?
It's smaller, and hence easier to read (and extend, should that
ever be necessary).
Jan
More information about the Binutils
mailing list