[gold][patch] Factor the should include member to a new function

Ian Lance Taylor iant@google.com
Tue Mar 9 17:59:00 GMT 2010


Rafael Espindola <espindola@google.com> writes:

> 2010-03-08   Rafael Espindola  <espindola@google.com>
>
> 	* archive.cc (should_include_member): New.
> 	(Archive::add_symbols): Use should_include_member.
> +// When we see a symbol in an archive we might decide to include the member,
> +// not include the member or be undecided. This enum represents these
> +// possibilities.

Two spaces after period.

> +      if (symlen + 1 > *tmpbuflen) {
> +        tmpbuf = static_cast<char*>(realloc(tmpbuf, symlen + 1));
> +        *tmpbufp = tmpbuf;
> +        *tmpbuflen = symlen + 1;
> +
> +      }

Opening brace should go on the next line.  Please remove the blank
line.

This should call xrealloc rather than realloc; that is a bug in the
current code, but might as well fix it now.

This is OK with those changes.

Thanks.

Ian



More information about the Binutils mailing list