2.18 ar/ranlib glitch for mips elf64

Paul Koning Paul_Koning@Dell.com
Fri Jun 4 18:27:00 GMT 2010


> > In trying to build a toolchain that can handle MIPS N64, I ran into
> an
> > issue for that case.  I built a pile of object files (those are
> > elf64-tradlittlemips BFD format).  Built an archive with "ar cq" and
> > that worked.  But then attempts to look at that archive with ar or
> > ranlib fail with "File format is ambiguous" and "matching formats:
> > elf64-tradlittlemips ecoff-littlemips ecoff-bigmips".
> >
> > I noticed the same issue applies to the libgcc.a that the GCC build
> > process creates.  Readelf tells me that every member in the archive
> is
> > elf64, so I have no idea where those ecoff things come from.  I see
> no
> > way to tell ar what the actual format is.
> >
> > Should I use a newer binutils?  Should I yank ecoff support out?
> (That
> > certainly wouldn't bother me...)
> 
> Try the latest released version.

Trying that now.

> Also which "ar" are you referring to above?  Is it the system ar or
the
> ar you just built?  If you are in a cross environment, I don't think
> you
> can use the system ar.

Sorry, I was using shorthand.  I meant the ar and ranlib that were built
in the cross build process.

	paul



More information about the Binutils mailing list