opcodes porting prolem

zhangle dash.z@163.com
Wed Jun 2 07:06:00 GMT 2010


Thank you very much!
I have solved the problem and it is just like what you said that I should
define the operand as "simm-21" other than "f-simm21".
I use cgen-1.1 and I generate the output opcode files just by "make
stamp-arca". There are no errors coming out and the results are
satisfactory.
Now I meet another obstacle blocking on my way to gas porting.
When I am building the gas directory, there are some errors saying some of
the functions I used in the tc-arca.c file are undeclared. These functions
are mostly called from the file of cgen.c.
I guess this has something to do with the cgen interface function and I
don't know where should I add or modify.
I notice that in the "md_begin()" function there is a comment "cgen
initialization interface" but there are not any code following at all.
I finish all the work mentioned in the cgen manual about gas porting and I
take openrisc as a template to help my porting. However it still doesn't
work.
Looking forward to your reply!

PS:my error log


Doug Evans-3 wrote:
> 
> On Mon, May 31, 2010 at 6:33 AM, zhangle <dash.z@163.com> wrote:
>>
>> I am doing opcodes porting to a new target and when I compile the source
>> directory it comes out this error.
>> I am sure I have added all dependencies to the relating files
>> The following is my error log.
>> Can any of you tell me where I am doing wrong?
>>
>> arca-opc.c:94: error: `ARCA_OPERAND_F_SIMM21' undeclared here (not in a
>> function)
>> [...]
>> arca-opc.c:100: error: `ARCA_OPERAND_F_SIMM10' undeclared here (not in a
>> function)
>> [...]
>> arca-opc.c:130: error: `ARCA_OPERAND_F_UIMM21' undeclared here (not in a
>> function)
> 
> By convention, operands don't have a prefix like the "f-" prefix that
> instruction fields have.
> 
> Guessing,
> have you accidentally written "f-simm21" for an operand in your .cpu
> file where you should have written "simm21" ?
> [and similarly for simm10 and uimm21]
> IOW, I would expect to see ARCA_OPERAND_SIMM21, not ARCA_OPERAND_F_SIMM21.
> 
> Also, which version of cgen are you using?
> The cgen in cvs head will flag operand spelling errors (or at least
> try to - I can get it to flag an error in a simple experiment).
> 
> 
http://old.nabble.com/file/p28750866/gas_errorlog.txt gas_errorlog.txt 
-- 
View this message in context: http://old.nabble.com/opcodes-porting-prolem-tp28731034p28750866.html
Sent from the Sourceware - binutils list mailing list archive at Nabble.com.



More information about the Binutils mailing list