[PATCH] rename amdfam15 flag to bdver1
Quentin Neill
quentin.neill.gnu@gmail.com
Fri Jan 29 21:24:00 GMT 2010
Hi,
This patch changes the -mtune=amdfam15 to -mtune=bdver1.
Tested with "make -k check".
Okay to commit?
gas/
* config/tc-i386.c (cpu_arch): Change amdfam15 to bdver1.
(i386_align_code): Rename PROCESSOR_AMDFAM15 to PROCESSOR_BDVER1.
* config/tc-i386.h (processor_type): Same.
* doc/c-i386.texi: Change amdfam15 to bdver1.
opcodes/
* i386-gen.c (cpu_flag_init): Rename CPU_AMDFAM15_FLAGS
to CPU_BDVER1_FLAGS
* i386-init.h: Regenerated.
testsuite/
* gas/i386/i386.exp: Rename amdfam15 test cases to bdver1.
* gas/i386/nops-1-bdver1.d: Renamed test case to
gas/i386/x86-64-nops-1-bdver1.d.
* gas/i386/nops-1-amdfam15.d: Renamed test case to
gas/i386/x86-64-nops-1-amdfam15.d.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 7007_bdver1.diff
Type: application/octet-stream
Size: 6638 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/binutils/attachments/20100129/5a81a750/attachment.obj>
More information about the Binutils
mailing list