gold patch committed: Rename some variables

Ian Lance Taylor
Tue Jan 5 19:30:00 GMT 2010

I've found myself confused a couple of times by the variable name
"def".  I renamed it to "is_default_version".  I also renamed some
other variables to be clearer.  Committed to mainline.


2010-01-05  Ian Lance Taylor  <>

	* (Symbol_table::add_from_object): Rename def parameter
	to is_default_version.  Rename insdef to insdefault.
	(Symbol_table::add_from_relobj): Rename def to is_default_version
	and local to is_forced_local.
	(Symbol_table::add_from_pluginobj): Likewise.
	(Symbol_table::add_from_dynobj): Likewise.
	(Symbol_table::define_special_symbol): Rename insdef to

-------------- next part --------------
A non-text attachment was scrubbed...
Name: foo.patch
Type: text/x-diff
Size: 10053 bytes
Desc: def
URL: <>

More information about the Binutils mailing list