[gold patch committed]: Define IRELATIVE relocs

Ian Lance Taylor iant@google.com
Wed Aug 4 10:02:00 GMT 2010


This patch defines the IRELATIVE relocs for the gold targets.  While
doing this I noticed that the old VTINHERIT and VTENTRY relocs were
misnamed for x86_64, so I corrected the names.  Committed to mainline.

Ian

elfcpp/ChangeLog

2010-08-04  Ian Lance Taylor  <iant@google.com>

	* i386.h (R_386_IRELATIVE): Define.
	* powerpc.h (R_POWERPC_IRELATIVE): Define.
	(R_PPC_RELAX32, R_PPC_RELAX32PC): Don't define.
	(R_PPC_RELAX32_PLT, R_PPC_RELAX32PC_PLT): Don't define.
	* sparc.h (R_SPARC_IRELATIVE): Define.
	* x86_64.h (R_X86_64_IRELATIVE): Define.
	(R_X86_64_GNU_VTINHERIT): Rename from R_386_GNU_VTINHERIT.
	(R_X86_64_GNU_VTENTRY): Rename from R_386_GNU_VTENTRY.

gold/ChangeLog

2010-08-04  Ian Lance Taylor  <iant@google.com>

	* x86_64.cc (Target_x86_64::Scan::local): Use
	R_X86_64_GNU_VTINHERIT instead of R_386_GNU_VTINHERIT and
	R_X86_64_GNU_VTENTRY instead of R_386_GNU_VTENTRY.
	(Target_x86_64::Scan::global): Likewise.
	(Target_x86_64::Relocate::relocate): Likewise.
	(Target_x86_64::Relocatable_size_for_reloc::get_size_for_reloc):
	Likewise.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: foo.patch
Type: text/x-diff
Size: 5514 bytes
Desc: IRELATIVE
URL: <https://sourceware.org/pipermail/binutils/attachments/20100804/148e0463/attachment.bin>


More information about the Binutils mailing list