-gc-sections and ARM unwinding tables
Nick Clifton
nickc@redhat.com
Thu Feb 22 11:12:00 GMT 2007
Hi Paul,
> 2007-02-15 Paul Brook <paul@codesourcery.com>
>
> bfd/
> * elflink.c (gc_mark_hook_fn): Remove.
> (_bfd_elf_gc_mark): Rename gc_mark_hook_fn to elf_gc_mark_hook_fn.
> (bfd_elf_gc_sections): Ditto. Call gc_mark_extra_sections.
> * elf-bfd.h (elf_gc_mark_hook_fn): Define.
> (elf_backend_data): Add gc_mark_extra_sections.
> * elfxx-target.h (elf_backend_gc_mark_extra_sections): Provide default
> definition.
> (elfNN_bed): Add elf_backend_gc_mark_extra_sections.
> * elf32-arm.c (elf32_arm_gc_mark_extra_sections): New function.
> (elf_backend_gc_mark_extra_sections): Define.
>
> ld/testsuite/
> * ld-arm/arm-elf.exp (armelftests): Add gc-unwind.h.
> * ld-arm/gc-unwind.s: New file.
> * ld-arm/gc-unwind.d: New file.
Approved - please apply.
Cheers
Nick
More information about the Binutils
mailing list