RFC: Map GNU attributes section to PT_GNU_STACK segment
Nick Clifton
nickc@redhat.com
Wed Aug 15 16:40:00 GMT 2007
Hi H.J.
> The current usage of the PT_GNU_STACK segment is the flags field
> only. All other fields are ignored. The new segment ignores the
> flags field. Overloading the PT_GNU_STACK segment seems a good
> idea to me since it is totally backward and forward compatible.
I agree that it is forward and backward compatible. I am just worried that the
name of the segment, if set to PT_GNU_ATTRIBUTES or left as PT_GNU_STACK, would
be confusing. I think that we ought to have a more generic type of name and
then have a well defined scheme for storing information in this segment.
> That is what my proposal does. The only difference is I call the
> new segment PT_GNU_ATTRIBUTES. I don't mind we use a differrent
> name at all. The loader-accessible information belongs to the GNU
> attributes section and it is extendable.
True, so maybe we ought to have a GNU_STACK attribute and use that. For
backwards compatibility we can still set the flags of the segment
appropriately, but that would only be for backwards compatibility. Any future
uses of the segment would not make use of the flags to specify any information.
Cheers
Nick
More information about the Binutils
mailing list