[Patch/pe-coff] : Add native spelling of import lib names to dynamic lib search

Ross Ridge rridge@csclub.uwaterloo.ca
Tue Jun 20 07:39:00 GMT 2006


Danny Smith wrote:
>However, the native naming convention for these import libs is "foo.lib"
>and gld_i386pe_open_dynamic_archive does not currently recognize this
>name format. This means that doing something like -L/path/to/sdk -lfoo32
>could link directly to "foo32.dll", rather than find the import lib
>"foo32.lib". 

Umm... doing something like -L/path/to/sdk -lfoo32 already works for
me with ld.  Am I missing something here?

					Ross Ridge



More information about the Binutils mailing list