[PATCH] x86: fix gas' relocation type selection

H. J. Lu hjl@lucon.org
Mon Jul 18 14:59:00 GMT 2005


On Mon, Jul 18, 2005 at 07:50:21AM -0600, Jan Beulich wrote:
> Relocation type selection up to now was dependent on the current code
> size
> model, but it instead should exclusively depend on the output file
> format
> (for example, even when in 64-bit code but in a 32-bit object, i386
> relocations should be used rather than x86-64 ones [or perhaps a
> mixture of
> both]).
> 

There are

    case bfd_target_elf_flavour:
      {
        if (flag_code == CODE_64BIT)
          use_rela_relocations = 1;

I don't see how your patch will change anything. And I don't like
using use_rela_relocations for 64bit mode checking. It makes code
less readable.


H.J.



More information about the Binutils mailing list