[Patch] Strip path components from internal dll name
Ben Elliston
bje@au.ibm.com
Tue Jan 18 00:06:00 GMT 2005
Danny Smith <danny_smith_0000@yahoo.co.nz> writes:
> The MS utilities avoid the import lib problem by disallowing pathnames
> as a NAME or LIBRARY arg in a .def file. For example, with this def file
>
> LIBRARY "c:/foo.dll"
> EXPORTS
> foo
>
> the comamnd
> lib /MACHINE:IX86 /DEF:foo.def
>
> results in following:
> foo.def : warning LNK4093: Drive/Directory component ignored in
> "LIBRARY" statement
> Creating library foo.lib and object foo.exp
>
> The following patch does same for ld and dlltool.
Can you please check the (new) .DEF file documentation to see if it
needs updating? Thanks,
Ben
More information about the Binutils
mailing list