[RFA] fix parameter name discrepancy...

Joel Brobecker brobecker@gnat.com
Thu Sep 9 17:38:00 GMT 2004


... Between comment and reality.

In the code, the second parameter of bfd_sections_find_if() is called
"operation". However, the documentation calls it "func". I am not sure
what the conventions are in binutils, so it might actually be
deliberate, but I'm pointing it out anyway.

2004-09-09  Joel Brobecker  <brobecker@gnat.com>

        * section.c (bfd_sections_find_if): Fix parameter name in
        comment to match code.

Comment change only. Not tested. Should I commit?

-- 
Joel
-------------- next part --------------
Index: section.c
===================================================================
RCS file: /cvs/src/src/bfd/section.c,v
retrieving revision 1.75
diff -u -p -r1.75 section.c
--- section.c	21 Jul 2004 15:42:57 -0000	1.75
+++ section.c	9 Sep 2004 17:33:53 -0000
@@ -1123,17 +1123,17 @@ FUNCTION
 SYNOPSIS
 	asection *bfd_sections_find_if
 	  (bfd *abfd,
-	   bfd_boolean (*func) (bfd *abfd, asection *sect, void *obj),
+	   bfd_boolean (*operation) (bfd *abfd, asection *sect, void *obj),
 	   void *obj);
 
 DESCRIPTION
-	Call the provided function @var{func} for each section
+	Call the provided function @var{operation} for each section
 	attached to the BFD @var{abfd}, passing @var{obj} as an
 	argument. The function will be called as if by
 
-|	func (abfd, the_section, obj);
+|	operation (abfd, the_section, obj);
 
-	It returns the first section for which @var{func} returns true.
+	It returns the first section for which @var{operation} returns true.
 
 */
 


More information about the Binutils mailing list