RFC: Remove sec->name and bfd_section_name
Ian Lance Taylor
ian@wasabisystems.com
Tue May 25 20:47:00 GMT 2004
"H. J. Lu" <hjl@lucon.org> writes:
> I am working on a patch to get rid of sec->name. Please use
> bfd_get_section_name for section name.
>
> BTW, we have both
>
> #define bfd_get_section_name(bfd, ptr) ((ptr)->name + 0)
> #define bfd_section_name(bfd, ptr) ((ptr)->name)
>
> Their usages are very inconsistent. I am planning to rename
>
> #define bfd_section_name(bfd, ptr) ((ptr)->name)
>
> to
>
> #define bfd_section_ident(bfd, ptr) ((ptr)->name)
I don't think that is a good idea. If we want to fix the issue of
diagnostics, let's fix it. Let's not put in a confusing temporary
patch.
> and add
>
> #define bfd_set_section_name(bfd, ptr, name) ((ptr)->name = (name), TRUE)
That seems reasonable.
Ian
More information about the Binutils
mailing list