problem building glibc-2.3.2 with gcc-3.4.0 andbinutils-2.15.90.0.3 for m68k

C Jaiprakash, Noida C.Jaiprakash@noida.hcltech.com
Fri Jul 23 08:53:00 GMT 2004


Hi,
  I also had ran into same problem while building glibc, however I think problem is at following line
#,"a",@progbits in below assembly. 

#APP
        .section .gnu.warning.sigstack
        .previous
#NO_APP
        .section        .gnu.warning.sigstack;
        #,"a",@progbits 

I just tried removing it, assemblt dont complain after that. This is coming from this defines in glibc

/* Tacking on "\n\t#" to the section name makes gcc put it's bogus
   section attributes on what looks like a comment to the assembler.  */
#  ifdef HAVE_SECTION_QUOTES
#   define __sec_comment "\"\n\t#\""
#  else
#   define __sec_comment "\n\t#"
#endif
#  endif

I am not sure where this should be fixed, though comment above says that this should appear as comment to assembler. But for m68k it is not appearing as a comment.

Regards,
C Jaiprakash

> While testing all the targets crosstool supports with the new combination of tools
> (gcc-3.4.0 and binutils-2.15.90.0.3),
> I ran into an error with --host=x86-linux --target m68k-linux:
>
> localealias.s:544: Error: junk at end of line, first unrecognized character is `,'
>
> Here are lines 544 to 546 of localealias.s:
>      544         .local  lock
>      545         .comm   lock,24,2
>      546         .section        __libc_freeres_ptrs
> So I guess it didn't like the ,24,2 on the .comm line.

No, gas is actually complaining about line 547 (it does not properly count
lines in #APP/#NO_APP sections).  See the thread starting at
<http://sources.redhat.com/ml/binutils/2004-04/msg00646.html>.

Andreas.



More information about the Binutils mailing list