PATCH: Remove bfd_comdat_info and move section_already_linked
Nick Clifton
nickc@redhat.com
Tue Jul 20 17:15:00 GMT 2004
Hi H.J.
> > I like it, except that it seems to me that you could leave
> > section_already_linked where it is, and just provide a bfd xvec
> > predicate. That would save some code duplication, which helps
> > in maintaining the linker.
> >
>
> The problem is that piece of code can be very much format specific. I
> have a follow-on patch to fix
>
> http://sources.redhat.com/bugzilla/show_bug.cgi?id=246
>
> My patch needs to access ELF backend. To do it in the linker, I will
> need to add another field to bfd xvec and we have to do more checking
> on input to see if it is ELF. I think the code duplication is very
> minimum here.
Well you still have the ...section_already_linked() code duplicated
three times. That could be reduced. Plus there is a problem in that
some of the COFF based ports do not currently include cofflink.lo when
building libbfd.a, so that there is an unresolved reference to
_bfd_coff_section_already_linked().
How about this variation on your patch which adds in the necessary
fixes to bfd/configure.in and also creates a generic
section_already_linked() function which takes file format specific
helper functions as arguments ?
Cheers
Nick
-------------- next part --------------
A non-text attachment was scrubbed...
Name: hj.4.patch
Type: text/x-patch
Size: 67470 bytes
Desc: Small variation on H.J.'s patch
URL: <https://sourceware.org/pipermail/binutils/attachments/20040720/6b8c397a/attachment.bin>
More information about the Binutils
mailing list