Macro name and comment fixes for gas/tc-mips.c
Wed Jan 7 23:06:00 GMT 2004
> At Wed, 7 Jan 2004 21:48:58 +0000 (UTC), "Ian Lance Taylor" wrote:
> > I propose that we rename the macro to ISA_HAS_NONBRANCH_DELAYS to
> > avoid such confusion. This patch does that rename, and also fixes the
> > comment for this macro and for the gpr_interlocks macro.
> Looking at ISA_HAS_COPROC_DELAYS a bit more carefully, I wonder if it
> might just make more sense to fix "cop_interlocks" to include the
> appropriate ISAs (which have interlocks), and check it consistently,
> rather than checking both ISA_HAS_COPROC_DELAYS and cop_interlocks...
AFAICS it's too often used outside a cop context for that.
More information about the Binutils