[wip] BFD from an arbitrary object; Was: provide pass-through value in bfd_elf_bfd_from_remote_memory
Alan Modra
amodra@bigpond.net.au
Sat Feb 14 04:15:00 GMT 2004
On Fri, Feb 13, 2004 at 09:34:03PM -0500, Ian Lance Taylor wrote:
> Andrew Cagney <cagney@gnu.org> writes:
> > - is the theory ok?
> Looks good to me.
I think it's a good idea too. I can't see the sense in those bread,
bwrite etc. names though. Why not simply read, write etc.? bfd_bread
and bfd_bwrite were added when I needed to make changes to bfd_read
and bfd_write, but thought it a good idea to keep the old functions
for backward compatibility. Let's not perpetuate silly names.
Hmm, unless some system #define's read, write etc.
--
Alan Modra
IBM OzLabs - Linux Technology Centre
More information about the Binutils
mailing list