News MIPS option -mno-shared

Richard Sandiford rsandifo@redhat.com
Fri Dec 10 09:34:00 GMT 2004


Ian Lance Taylor <ian@wasabisystems.com> writes:
>> Yeah, this has been on my to-do list for a while ;)  Are you going to
>> do the same thing for n32 or are you only interested in o32?
>
> For n32 the patch is to gcc, not the binutils.  I have that patch, but
> it's a new feature and as such is not going to be acceptable in stage
> 3.  I'll submit it when gcc goes back to stage 1.

OK.  I was just wondering if there was a specific reason for making
.cpload (the o32 pseudo-op) use _gp but not .cpsetup (the n32 pseudo-op).
I realise that most n32 code uses %hi/lo(%neg(%gp_rel(...))) directly,
but some hand-written asm does use .cpsetup.

> The gcc patch looks more or like the following, plus some obvious
> mips.h and doc stuff.

Looks good, but would it be possible to use SYMBOL_GENERAL instead of
adding a new symbol type like SYMBOL_GP?  In hindsight, "SYMBOL_ABSOLUTE"
would probably have been a better name than SYMBOL_GENERAL.

Richard



More information about the Binutils mailing list