Rename -mfix-vr4122-bugs to -mfix-vr4120.
Thiemo Seufer
ica2_ts@csv.ica.uni-stuttgart.de
Tue Apr 13 22:35:00 GMT 2004
Richard Sandiford wrote:
> I'd like to change the name of -mfix-vr4122-bugs to -mfix-vr4120. Reasons:
>
> (1) Some of the workarounds selected by -mfix-vr4122-bugs also apply to the
> VR4181 (which, like the VR4122, uses a VR4120 core).
>
> (2) VR4120 code is selected by -march=vr4120, not -march=vr4122.
>
> (3) It's more consistent with the options recently added to GCC,
> e.g. -mfix-sb1, -mfix-r4000.
>
> (4) There are some errata that (AIUI) only apply to the version of the
> VR4120 that's used in the VR4181. "Some time soon", I'll be submitting
> a patch to cover these errata too.
>
> I think the only obvious argument against is backwards compability.
> However, as the documentation says, the option is only really intended
> for use with the equivalen gcc option, and since that option was only
> recently added to FSF HEAD, there shouldn't really be much problem.
>
> Tested on mips{,64}{,el}-elf, etc. OK to install?
Ok.
Thiemo
More information about the Binutils
mailing list