configure problems: possibly undefined macro: AS_FOR_TARGET

Daniel Jacobowitz drow@mvista.com
Mon Jan 20 05:29:00 GMT 2003


On Mon, Jan 20, 2003 at 01:03:00AM +0200, Kai Henningsen wrote:
> corsepiu@faw.uni-ulm.de (Ralf Corsepius)  wrote on 08.01.03 in <1042008003.930.4922.camel@mccallum.corsepiu.faw.uni-ulm.de>:
> 
> > Am Die, 2003-01-07 um 18.28 schrieb Charles Wilson:
> > > > m Mon, 2003-01-06 um 22.17 schrieb Christian Jönsson:
> > >
> >
> > > >> well, regardless, it is suggested recently on the cygwin list that
> > > >> binutils or more correct I guess, the top-level configure.in to have
> > > >> this patch in it
> >
> > > > => This patch is useless.
> > >
> > > You mean, in your opinion this patch is not worthy of application.
> > No, I say, this patch does _not_ solve the problem of wanting
> > autoconf-2.13 or autoconf-2.5x in general.
> >
> > >  It is certainly NOT useless, since it SOLVES THE PROBLEM.
> > No, not in general.
> >
> > It only helps out the heuristics your autoconf-wrapper is based upon and
> > therefore only helps Cygwin and those others vendor which use hacked
> > autoconfs or wrappers similar to yours.
> 
> I should point out that Debian also has such a wrapper (and probably all  
> Debian-derived distributions that do ship both versions).
> 
> Looks to me as if it's the only game in town.

At the risk of covering old ground, it's not an accident that Debian's
wrapper defaults to 2.13 in the absence of an AC_PREREQ.

-- 
Daniel Jacobowitz
MontaVista Software                         Debian GNU/Linux Developer



More information about the Binutils mailing list