gas symbols.c functions
Alan Modra
amodra@bigpond.net.au
Thu Feb 21 23:50:00 GMT 2002
On Fri, Feb 22, 2002 at 01:48:21PM +1100, Ben Elliston wrote:
> These are all functions, yet are named as if they might be macros or
> enum constants (in violation of the GNU coding standard). Ideally,
> these functions should also be prefixed with `symbol', not `s'. If
> this was done, the patch would be *huge*. Comments?
Grin. I suppose you could rename the functions in symbols.c, and
then define macros like
#define S_IS_FUNCTION symbol_is_function
That should satisfy the standard without a huge patch.
Seriously, many of these functions are macros in old non-bfd
targets. And no, I don't advocate more macros.
Alan
More information about the Binutils
mailing list