[PATCH] readelf section names

Nick Clifton nickc@cambridge.redhat.com
Fri Oct 12 01:58:00 GMT 2001


Hi Jakub,

> I find SHT_LOPROC+123456 section names inconsistent with other printed
> section names which are typically stringified section type without the SHT_
> prefix. Do you agree?

Yes :-)

> It makes the output more readable too because there is
> more space after section name.
> 
> 2001-10-11  Jakub Jelinek  <jakub@redhat.com>
> 
> 	* readelf.c (get_section_type_name): Don't print SHT_ prefix for
> 	LOPROC, LOOS and LOUSER.

Approved.  Please apply.

Cheers
        Nick



More information about the Binutils mailing list