[patch] bfd [pei]: do not set empty DataDirectory entries

DJ Delorie dj@delorie.com
Mon Sep 25 18:34:00 GMT 2000


Could you redo the patch so that there isn't an assignment inside the
if condition?  I find the way you did it hard to read, as they always
look like typos (gcc even warns about it).  For the first part of the
diff, I'd use a separate conditional after the existing assignments,
and for the second, I'd add the test for pei_section_data (abfd,
sec)->virt_size to the existing conditional.

Also, when generating patches on windows, use a cygwin-aware patch
program redirected to a binary mount so that the file names have POSIX
syntax and the ^Ms are removed.  While I can work around this problem
when applying the patch, it's annoying.

Otherwise, the logic of the patch looks OK.


More information about the Binutils mailing list