A patch for ld/Makefile.am

H . J . Lu hjl@valinux.com
Thu Jun 29 23:03:00 GMT 2000


The problem is we may have both deffilep.y and ldgram.y. We need
YLWRAP for parallel build on SMP machine. Is that ok to install?

-- 
H.J. Lu (hjl@gnu.org)
---
2000-06-29  H.J. Lu  <hjl@gnu.org>

	* Makefile.am (EXTRA_ld_new_SOURCES): Set to deffilep.y for
	automake to use YLWRAP.
	* Makefile.in: Rebuild.

Index: Makefile.am
===================================================================
RCS file: /work/cvs/gnu/binutils/ld/Makefile.am,v
retrieving revision 1.27
diff -u -p -r1.27 Makefile.am
--- Makefile.am	2000/06/23 19:11:25	1.27
+++ Makefile.am	2000/06/30 05:56:27
@@ -734,6 +734,9 @@ ez8002.c: $(srcdir)/emulparams/z8002.sh 
   $(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/z8000.sc ${GEN_DEPENDS}
 	${GENSCRIPTS} z8002 "$(tdir_z8002)"
 
+# We need this for automake to use YLWRAP.
+EXTRA_ld_new_SOURCES = deffilep.y
+
 ld_new_SOURCES = ldgram.y ldlex.l lexsup.c ldlang.c mri.c ldctor.c ldmain.c \
 	ldwrite.c ldexp.c ldemul.c ldver.c ldmisc.c ldfile.c ldcref.c
 ld_new_DEPENDENCIES = $(EMULATION_OFILES) $(EMUL_EXTRA_OFILES) $(BFDLIB) $(LIBIBERTY) $(INTLDEPS)


More information about the Binutils mailing list