[PATCH]Add --style switch to binutils

Ken Block block@zk3.dec.com
Tue Jun 20 13:38:00 GMT 2000

If people would prefer --style be --demangler, I have no objections.
--style is what is used in H.J. Lu's binutils. Previously, it was

There is another switch --demangler which takes the name of a shared
object and an entry point. These are used to dynamically load a
demangler from a shared object.

  { {"demangler", no_argument, NULL, OPTION_DEMANGLER},
      '\0', "DSO:FUNCTION", N_("Set DSO and demangler function"),

I'm not submitting that patch at this time since it has not been view
favorably in the past.

DJ Delorie wrote:

> "--style" sounds like an awfully generic name.  How about
> "--demangler" instead?

More information about the Binutils mailing list