GAS for ARM: Reject ASR/LSR/ROR with immediate of 0
Nick Clifton
nickc@redhat.com
Fri Aug 18 12:29:00 GMT 2000
Hi Richard,
: So make it an as_warn, rather than an as_tsktsk. Then the user can
: add -X to the assembly and will get an error.
Done.
: ! if (num == 0)
: ! {
: ! as_tsktsk (_("Shift of 0 ignored."));
: ! >>> shift = shift_names;
: ! assert (shift->properties->index == SHIFT_LSL);
: ! }
:
: On a point of style, I find assigning the "whole array" here confusing.
: It would be much clearer if this read
:
: shift = &shift_names[0];
I kind of liked it :-) Oh well, anything for clarity and ease of
comprehension.
Done.
Cheers
Nick
More information about the Binutils
mailing list